校园网规划与设计(附加完整word文档和pkt文件)

点击下面的链接可获得报告和pkt文件

校园网规划与设计报告和pkt文件

一.设计要求

  1. 该网络至少需要有9个网段(每个网段至少2台主机(两个IP地址)),每个网段的起始地址段为:192.168.开头,第三位是你的学号,比如:你的学号是18,则你的地址段为:192.168.18.开头。
  2. 拓扑图至少有5台路由器,核心层为2台三层交换机,汇聚层3台交换机,接入层6台交换机。
  3. 本设计模拟一个校园网的规划与设计,该校园有三个园区,东区、南区和北区。园区网外部路由(东区、南区和北区路由器)之间的链路层协议选用PPP、路由协议选用rip。
  4. 园区网边界路由器启用NAT技术。
  5. 画出网络拓扑图。
  6. 在设计中要涉及虚拟局域网,在接入层交换机配置VLAN。
  7. 在两台核心交换机之间提供冗余链路。
  8. 需要有Web网站的管理:具备WWW,FTP功能,配置Web服务器。
  9. 需要配置DHCP服务。
  10. 体现策略路由。
  11. VRRP技术的运用
  12. 体现IPsec技术
  13. 体现PVST技术

二.拓扑图设计

在这里插入图片描述

三.IP规划表

在这里插入图片描述

四.主要技术与相应配配置

1.主要技术功能简介

Vlan功能简介: 通过vlan划分网段,隔离广播域
**链路聚合简介:**捆绑端口,实现带宽翻倍
HSRP功能简介: 设置共同的虚拟网关,优先级,冗余链路,当主干链路出故障时能自动启动备份链路
MSTP功能简介: 通过设计优先级来阻塞端口,可以解决交换机环路问题,减少数据包在网络循环的兜圈子
静态路由功能简介: 因为公网路由路由器器很多,如果边界配置动态路由,则边界路由器学习的路由记录就很多,会很占路由器内存及查找效率。所以只能采用默认路由
**动态路由简介RIP:**公网有很多路由器采用人工分配的工作量大,所以采用RIP协议
DHCP功能简介: 学习的主机很多,人工分配ip的工作量大,所以采用DHCP服务自动获取
NAT功能简介: 学校局域网用的都是私有地址,私有地址是不能访问公网地址的,需要把私有地址转换翻译成公网地址才能访问公网
Ipsec功能简介: 学校局域网是私有的,互联网用户是不能访问的。所以要配置VPN加密通道
GRE功能简介: 各校区园区的局域网是独立的,要实现各校区互通,要配置GER隧道,忽略公网路由器,直接看成一条网线连接园区边界路由器。

2.东区园区配置

2.1。各设备及端口ip地址

内网服务器

在这里插入图片描述
FTP服务器

在这里插入图片描述

DNS服务器

在这里插入图片描述
DHCP服务器
在这里插入图片描述
核心层交换机CoreSW1

CoreSW1(config)#int f0/1
CoreSW1(config-if)#no switchport
CoreSW1(config-if)#ip address 172.16.0.2 255.255.255.252
CoreSW1(config-if)#int f0/23
CoreSW1(config-if)#no switchport 
CoreSW1(config-if)#ip address 10.0.1.254 255.255.255.0

核心层交换机CoreSW2

CoreSW2(config)#int f0/1
CoreSW2(config-if)#no switchport 
CoreSW2(config-if)#ip address 172.16.1.2 255.255.255.252

路由器R1

R1(config)#int f0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 172.16.0.1 255.255.255.252
R1(config-if)#int f0/1
R1(config-if)#no shutdown
R1(config-if)#ip address 172.16.1.2 255.255.255.252
R1(config-if)#int E1/1
R1(config-if)#no shutdown
R1(config-if)#ip address 60.60.60.60 255.255.255.252

2.2.VLAN及主干链路

接入层交换机AccessSW1

AccessSW1(config)#vlan 10
AccessSW1(config-vlan)#vlan 20
AccessSW1(config-vlan)#int range f0/1-10
AccessSW1(config-if-range)#switchport access vlan 10
AccessSW1(config-if-range)#int range f0/11-20
AccessSW1(config-if-range)#switchport access vlan 20
AccessSW1(config-if)#int f0/24
AccessSW1(config-if)#switchport mode trunk

接入层交换机AccessSW2

ACCESSSW2(CONFIG)#VLAN 30
ACCESSSW2(CONFIG-VLAN)#VLAN 40
ACCESSSW2(CONFIG-VLAN)#INT RANGE F0/1-10
ACCESSSW2(CONFIG-IF-RANGE)#SWITCHPORT ACCESS VLAN 30
ACCESSSW2(CONFIG-IF-RANGE)#INT RANGE F0/11-20
ACCESSSW2(CONFIG-IF-RANGE)#SWITCHPORT ACCESS VLAN 40
AccessSW2(config-if)#int f0/24
AccessSW2(config-if)#switchport mode trunk

汇聚层交换机ConvergeSW1

ConvergeSW1 (config)#vlan 10
ConvergeSW1 (config-vlan)#vlan 20
ConvergeSW1 (config-vlan)#vlan 30
ConvergeSW1 (config-vlan)#vlan 40
ConvergeSW1 (config)#int range f0/21-24
ConvergeSW1 (config-if-range)#switchport mode trunk

核心层交换机CoreSW1 VLAN及主干链路

CoreSW1(config)#ip routing
CoreSW1(config)#vlan 10
CoreSW1(config-vlan)#vlan 20
CoreSW1(config-vlan)#vlan 30
CoreSW1(config-vlan)#vlan 40
CoreSW1(config-vlan)#int f0/24
CoreSW1(config-if)#switchport trunk encapsulation dot1q
CoreSW1(config-if)#switchport mode trunk
CoreSW1(config-if)#int port-channel 1
CoreSW1(config-if)#switchport trunk encapsulation dot1q
CoreSW1(config-if)#switchport mode trunk
CoreSW1(config)#int vlan 10
CoreSW1(config-if)#ip address 192.168.18.1 255.255.255.240
CoreSW1(config-if)#int vlan 20
CoreSW1(config-if)#ip address 192.168.18.17 255.255.255.240
CoreSW1(config-if)#int vlan 30
CoreSW1(config-if)#ip address 192.168.18.33 255.255.255.240
CoreSW1(config-if)#int vlan 40 
CoreSW1(config-if)#ip address 192.168.18.49 255.255.255.240

核心层交换机CoreSW2 VLAN及主干链路

CoreSW2(config)#ip routing
CoreSW2(config)#vlan 10
CoreSW2(config-vlan)#vlan 20
CoreSW2(config-vlan)#vlan 30
CoreSW2(config-vlan)#vlan 40
CoreSW2(config)#int f0/24
CoreSW2(config-if)#switchport trunk encapsulation dot1q
CoreSW2(config-if)#switchport mode trunk
CoreSW2(config-if)#int port-channel 1
CoreSW2(config-if)#switchport trunk encapsulation dot1q
CoreSW2(config-if)#switchport mode trunk
CoreSW2(config)#int vlan 10
CoreSW2(config-if)#ip address 192.168.18.2 255.255.255.240
CoreSW2(config-if)#int vlan 20
CoreSW2(config-if)#ip address 192.168.18.18 255.255.255.240
CoreSW2(config-if)#int vlan 30
CoreSW2(config-if)#ip address 192.168.18.34 255.255.255.240
CoreSW2(config-if)#int vlan 40
CoreSW2(config-if)#ip address 192.168.18.50 255.255.255.240

2.3.链路聚合

核心层交换机CoreSW1

convergeSW1 (config)#int range g0/1-2
convergeSW1 (config-if-range)#channel-group 1 mode on

核心层交换机CoreSW2

ConvergeSW2 (config)#int range g0/1-2
ConvergeSW2 (config-if-range)#channel-group 1 mode on

2.4.网关冗余HSRP

核心层交换机CoreSW1

CoreSW1(config-if)#int vlan 10
CoreSW1(config-if)#standby 1 ip 192.168.18.14
CoreSW1(config-if)#standby 1 preempt
CoreSW1(config-if)#standby 1 priority 110
CoreSW1(config-if)#standby 1 track f0/1
CoreSW1(config-if)#int vlan 20
CoreSW1(config-if)#standby 1 ip 192.168.18.30
CoreSW1(config-if)#standby 1 preempt
CoreSW1(config-if)#standby 1 priority 105
CoreSW1(config-if)#standby 1 track f0/1
CoreSW1(config-if)#int vlan 30
CoreSW1(config-if)#standby 1 ip 192.168.18.46
CoreSW1(config-if)#standby 1 preempt
CoreSW1(config-if)#standby 1 priority 110
CoreSW1(config-if)#standby 1 track f0/1
CoreSW1(config-if)#int vlan 40
CoreSW1(config-if)#standby 1 ip 192.168.18.62
CoreSW1(config-if)#standby 1 preempt
CoreSW1(config-if)#standby 1 priority 105
CoreSW1(config-if)#standby 1 track f0/1

核心层交换机CoreSW2

CoreSW2(config-if)#int vlan 10
CoreSW2(config-if)#standby 1 ip 192.168.18.14
CoreSW2(config-if)#standby 1 preempt
CoreSW2(config-if)#standby 1 priority 105
CoreSW2(config-if)#standby 1 track f0/1
CoreSW2(config-if)#int vlan 20
CoreSW2(config-if)#standby 1 ip 192.168.18.30
CoreSW2(config-if)#standby 1 preempt
CoreSW2(config-if)#standby 1 priority 110
CoreSW2(config-if)#standby 1 track f0/1
CoreSW2(config-if)#int vlan 30
CoreSW2(config-if)#standby 1 ip 192.168.18.46
CoreSW2(config-if)#standby 1 preempt
CoreSW2(config-if)#standby 1 priority 105
CoreSW2(config-if)#standby 1 track f0/1
CoreSW2(config-if)#int vlan 40
CoreSW2(config-if)#standby 1 ip 192.168.18.62
CoreSW2(config-if)#standby 1 preempt
CoreSW2(config-if)#standby 1 priority 110
CoreSW2(config-if)#standby 1 track f0/1

2.5.生成树协议MSTP

汇聚层交换机ConvergeSW1

ConvergeSW1(config)#spanning-tree vlan 10,20,30,40

核心层交换机CoreSW1

CoreSW1(config)#spanning-tree vlan 10 priority 0
CoreSW1(config)#spanning-tree vlan 20 priority 4096
CoreSW1(config)#spanning-tree vlan 30 priority 0
CoreSW1(config)#spanning-tree vlan 40 priority 4096

核心层交换机CoreSW2

CoreSW2(config)#spanning-tree vlan 10 priority 4096
CoreSW2(config)#spanning-tree vlan 20 priority 0
CoreSW2(config)#spanning-tree vlan 30 priority 4096
CoreSW2(config)#spanning-tree vlan 40 priority 0

2.6.路由表

静态路由
核心层交换机CoreSW1

CoreSW1(config)#ip route 0.0.0.0 0.0.0.0 172.16.0.1

核心层交换机CoreSW2

CoreSW2(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.1

路由器R1

R1(config)#ip route 192.168.18.0 255.255.255.0 172.16.0.2
R1(config)#ip route 192.168.18.0 255.255.255.0 172.16.1.2
R1(config)#ip route 10.0.1.0 255.255.255.0 172.16.0.2
R1(config)#ip route 10.0.1.0 255.255.255.0 172.16.1.2
R1(config)#ip route 0.0.0.0 0.0.0.0 60.60.60.1
R1(config)#ip route 192.168.18.64 255.255.255.240 192.168.88.2
R1(config)#ip route 192.168.18.80 255.255.255.240 192.168.88.2
R1(config)#ip route 192.168.18.96 255.255.255.240 192.168.88.2
R1(config)#ip route 192.168.18.112 255.255.255.240 192.168.88.2
R1(config)#ip route 192.168.18.128 255.255.255.240 192.168.88.2

2.7.DHCP

DHCP服务器
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述

核心层交换机CoreSW1

CoreSW1(config)#service dhcp
CoreSW1(config)#int vlan 10
CoreSW1(config-if)#ip helper-address 10.0.1.4
CoreSW1(config-if)#int vlan 20
CoreSW1(config-if)# ip helper-address 10.0.1.4
CoreSW1(config-if)#int vlan 30
CoreSW1(config-if)# ip helper-address 10.0.1.4
CoreSW1(config-if)#int vlan 40
CoreSW1(config-if)# ip helper-address 10.0.1.4

核心层交换机CoreSW2

CoreSW2(config)#service dhcp
CoreSW2(config)#int vlan 10
CoreSW2(config-if)#ip helper-address 10.0.1.4
CoreSW2(config-if)#int vlan 20
CoreSW2(config-if)# ip helper-address 10.0.1.4
CoreSW2(config-if)#int vlan 30
CoreSW2(config-if)# ip helper-address 10.0.1.4
CoreSW2(config-if)#int vlan 40
CoreSW2(config-if)# ip helper-address 10.0.1.4

2.8.NAT地址转换

路由器R1

R1(config)#int range f0/0-1
R1(config-if)#ip nat inside
R1(config-if)#int e1/1
R1(config)#ip nat outside
R1(config-if)#access-list 10 permit 10.0.1.0 0.0.0.255
R1(config)#access-list 10 permit 192.168.18.0 0.0.0.255
R1(config)# ip nat inside source list 10 interface Ethernet1/1 overload

2.9.ipsec VPN

路由器R1

R1(config)#ip nat inside source static tcp 10.0.1.1 80 60.60.60.60 80
R1(config)#aaa new-model
R1(config)#aaa authentication login vec-a local
R1(config)#aaa authorization network vec-o local
R1(config)#username vec password 0 123
R1(config)#crypto isakmp policy 10
R1(config-isakmp)#hash md5
R1(config-isakmp)#authentication pre-share
R1(config-isakmp)#crypto isakmp client configuration group vecgroup
R1(config-isakmp-group)#key vec
R1(config-isakmp-group)#pool vecpool
R1(config-isakmp-group)#crypto ipsec transform-set map esp-3des esp-md5-hmac
R1(config)#crypto dynamic-map d-map 10
R1(config-crypto-map)#set transform-set map
R1(config-crypto-map)#reverse-route
R1(config-crypto-map)#crypto map map client authentication list vec-a
R1(config)#crypto map map isakmp authorization list vec-o
R1(config)#crypto map map client configuration address respond
R1(config)#crypto map map 10 ipsec-isakmp dynamic d-map
R1(config)#ip local pool vecpool 192.168.18.243 192.168.18.253
R1(config)#int e1/1
R1(config-if)#crypto map map
*Jan 3 07:16:26.785: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is ON

2.10.GRE隧道

路由器R1

R1(config)#int tunnel 1
R1(config-if)#tunnel source e1/1
R1(config-if)#tunnel destination 50.50.50.50
R1(config-if)#ip address 192.168.88.1 255.255.255.252
R1(config-if)#int tunnel 2 
R1(config-if)#tunnel source e1/1
R1(config-if)#tunnel destination 40.40.40.40
R1(config-if)#ip address 192.168.77.1 255.255.255.252

3.南区园区配置

3.1.各设备及端口ip地址

路由器R9

R9(config)#int f0/1
R9(config-if)#no shutdown
R9(config-if)#ip address 50.50.50.50 255.255.255.0
R9(config-if)#int f0/0
R9(config-if)#no shutdown
R9(config-if)#no ip address
R9(config-if)#int f0/0.1
R9(config-if)#encapsulation dot1q 50
R9(config-if)#ip address 192.168.18.78 255.255.255.240
R9(config-if)#int f0/0.2
R9(config-if)#encapsulation dot1q 60
R9(config-if)#ip address 192.168.18.94 255.255.255.240
R9(config-if)#int f0/0.3
R9(config-if)#encapsulation dot1q 70
R9(config-if)#ip address 192.168.18.110 255.255.255.240

3.2.VLAN技术

接入层交换机AccessSW3

AccessSW3(config)#vlan 50
AccessSW3(config)#vlan 60
AccessSW3(config)#int range f0/1-10
AccessSW3(config-if)#switchport access vlan 50
AccessSW3(config-if)#int range f0/11-20
AccessSW3(config-if)#switchport access vlan 60
AccessSW3(config-if)#int f0/24
AccessSW3(config-if)#switchport mode trunk

接入层交换机AccessSW4

AccessSW4(config)#vlan 70
AccessSW4(config)#int range f0/1-20
AccessSW4(config-if)#switchport access vlan 70
AccessSW4(config-if)#int f0/24
AccessSW4(config-if)#switchport mode trunk

核心层交换机ConvergeSW2

ConvergeSW2(config)#vlan 50
ConvergeSW2(config)#vlan 60
ConvergeSW2(config)#vlan 70
ConvergeSW2(config)#int f0/1
ConvergeSW2(config-if)#switchport mode trunk
ConvergeSW2(config-if)#int range f0/23-24
ConvergeSW2(config-if)#swithcport mode trunk

3.3.路由表

静态路由
路由器R9

R9(config)#ip route 0.0.0.0 0.0.0.0 50.50.50.1
R9(config)#ip route 10.0.1.0 255.255.255.0 192.168.88.1
R9(config)#ip route 192.168.18.0 255.255.255.240 192.168.88.1
R9(config)#ip route 192.168.18.16 255.255.255.240 192.168.88.1
R9(config)#ip route 192.168.18.32 255.255.255.240 192.168.88.1
R9(config)#ip route 192.168.18.48 255.255.255.240 192.168.88.1
R9(config)#ip route 192.168.18.112 255.255.255.240 192.168.66.6
R9(config)#ip route 192.168.18.128 255.255.255.240 192.168.66.6

3.4.DHCP

路由器R9

R9(config)#service dhcp
R9(config)#ip dhcp pool 50
R9(config)#network 192.168.18.64 255.255.255.240
R9(config)#default-router 192.168.18.78
R9(config)#dns-server 10.0.1.3
R9(config)#ip dhcp excluded-address 192.168.18.78
R9(config)#ip dhcp pool 60
R9(config)#network 192.168.18.80 255.255.255.240
R9(config)#default-router 192.168.18.94
R9(config)#dns-server 10.0.1.3
R9(config)#ip dhcp excluded-address 192.168.18.94
R9(config)#ip dhcp pool 70
R9(config)#network 192.168.18.96 255.255.255.240
R9(config)#default-router 192.168.18.110
R9(config)#dns-server 10.0.1.3
R9(config)#ip dhcp excluded-address 192.168.18.110

3.5.NAT地址转换

路由器R9

R9(config)#int range f0/0.1-0.3
R9(config-if)#ip nat inside
R9(config-if)#int f0/1
R9(config)#ip nat outside
R9(config)#access-list 10 permit 192.168.18.0 0.0.0.255
R9(config)# ip nat inside source list 10 interface f0/1 overload

3.6.GRE隧道

路由器R9

R9(config)#int tunnel 1
R9(config-if)#tunnel source f0/1
R9(config-if)#tunnel destination 60.60.60.60
R9(config-if)#ip address 192.168.88.2 255.255.255.252
R9(config-if)#int tunnel 2 
R9(config-if)#tunnel source f0/1
R9(config-if)#tunnel destination 40.40.40.40
R9(config-if)#ip address 192.168.66.5 255.255.255.252

4.北区园区配置

4.1.各设备及端口ip地址

路由器R10

R10(config)#int f0/1
R10(config-if)#no shutdown
R10(config-if)#ip address 40.40.40.40 255.255.255.0
R10(config-if)#int f0/0
R10(config-if)#no shutdown
R10(config-if)#no ip address
R10(config-if)#int f0/0.1
R10(config-if)#encapsulation dot1q 80
R10(config-if)#ip address 192.168.18.126 255.255.255.240
R10(config-if)#int f0/0.2
R10(config-if)#encapsulation dot1q 90
R10(config-if)#ip address 192.168.18.142 255.255.255.240

4.2.VLAN技术

接入层交换机AccessSW5

AccessSW5(config)#vlan 80
AccessSW5(config)#int range f0/1-20
AccessSW5(config-if)#switchport access vlan 80
AccessSW5(config-if)#int f0/24
AccessSW5(config-if)#switchport mode trunk

接入层交换机AccessSW6

AccessSW6(config)#vlan 90
AccessSW6(config)#int range f0/1-20
AccessSW6(config-if)#switchport access vlan 80
AccessSW6(config-if)#int f0/24
AccessSW6(config-if)#switchport mode trunk

汇聚层交换机ConvergeSW3

ConvergeSW3(config)#vlan 80
ConvergeSW3(config)#vlan 90
ConvergeSW3(config)#int f0/1
ConvergeSW3(config-if)#switchport mode trunk
ConvergeSW3(config-if)#int range f0/23-24
ConvergeSW3(config-if)#swithcport mode trunk

4.3.路由表

静态路由
路由器R10

R10(config)#ip route 0.0.0.0 0.0.0.0 40.40.40.1
R10(config)#ip route 10.0.1.0 255.255.255.0 192.168.77.1
R10(config)#ip route 192.168.18.0 255.255.255.240 192.168.77.1
R10(config)#ip route 192.168.18.16 255.255.255.240 192.168.77.1
R10(config)#ip route 192.168.18.32 255.255.255.240 192.168.77.1
R10(config)#ip route 192.168.18.48 255.255.255.240 192.168.77.1
R10(config)#ip route 192.168.18.64 255.255.255.240 192.168.66.5
R10(config)#ip route 192.168.18.80 255.255.255.240 192.168.66.5
R10(config)#ip route 192.168.18.96 255.255.255.240 192.168.66.5

4.4.DHCP

路由器R10

R10(config)#service dhcp
R10(config)#ip dhcp pool 80
R10(config)#network 192.168.18.112 255.255.255.240
R10(config)#default-router 192.168.18.126
R10(config)#dns-server 10.0.1.3
R10(config)#ip dhcp excluded-address 192.168.18.126
R10(config)#ip dhcp pool 90
R10(config)#network 192.168.18.128 255.255.255.240
R10(config)#default-router 192.168.18.142
R10(config)#dns-server 10.0.1.3
R10(config)#ip dhcp excluded-address 192.168.18.142

4.5.NAT地址转换

路由器R10

R10(config)#int range f0/0.1-0.2
R10(config-if)#ip nat inside
R10(config-if)#int f0/1
R10(config)#ip nat outside
R10(config)#access-list 10 permit 192.168.18.0 0.0.0.255
R10(config)# ip nat inside source list 10 interface f0/1 overload

4.6.GRE隧道

路由器R10

R10(config)#int tunnel 2
R10(config-if)#tunnel source f0/1
R10(config-if)#tunnel destination 60.60.60.60
R10(config-if)#ip address 192.168.77.2 255.255.255.252
R10(config-if)#int tunnel 3 
R10(config-if)#tunnel source f0/1
R10(config-if)#tunnel destination 50.50.50.4=50
R10(config-if)#ip address 192.168.66.6 255.255.255.252

5.公网配置

5.1.各设备端口ip地址

路由器R3

R3(config)#int f0/0
R3(config-if)#no shutdown
R3(config-if)#ip address 60.60.60.1 255.255.255.0
R3(config-if)#int s0/0/0
R3(config-if)#no shutdown
R3(config-if)#ip address 1.1.1.1 255.255.255.252

路由器R4

R4(config)#int S0/0/0
R4(config-if)#no shutdown
R4(config-if)#ip address 1.1.1.2 255.255.255.252
R4(config-if)#int s0/0/1
R4(config-if)#no shutdown
R4(config-if)#ip address 1.1.1.5 255.255.255.252

路由器R5

R5(config)#int s0/0/1
R5(config-if)#no shutdown
R5(config-if)#ip address 1.1.1.6 255.255.255.252
R5(config-if)#int s0/0/0
R5(config-if)#no shutdown
R5(config-if)#ip address 1.1.1.9 255.255.255.252
R5(config-if)#int f0/0
R5(config-if)#ip address 50.50.50.1 255.255.255.0

路由器R6

R6(config)#int s0/0/0
R6(config-if)#no shutdown
R6(config-if)#ip address 1.1.1.10 255.255.255.252
R6(config-if)#int s0/0/1
R6(config-if)#no shutdown
R6(config-if)#ip address 1.1.1.13 255.255.255.252

路由器R7

R7(config)#int s0/0/1
R7(config-if)#no shutdown
R7(config-if)#ip address 1.1.1.14 255.255.255.252
R7(config-if)#int s0/0/1
R7(config-if)#no shutdown
R7(config-if)#ip address 1.1.1.17 255.255.255.252
R7(config-if)#it f0/0 
R7(config-if)#ip address 40.40.40.1 255.255.255.0

路由器R8

R8(config)#int s0/0/0
R8(config-if)#no shutdown
R8(config-if)#ip address 1.1.1.18 255.255.255.252
R8(config-if)#int f0/0
R8(config-if)#no shutdown
R8(config-if)#ip address 222.222.222.1 255.255.255.0

5.2.路由表

动态RIP路由配置
路由器R3

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#network 1.0.0.0
R3(config-router)#network 60.60.60.0

路由器R4

R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#no auto-summary
R4(config-router)#network 1.1.1.0

路由器R5

R5(config)#router rip
R5(config-router)#version 2
R5(config-router)#no auto-summary
R5(config-router)#network 1.1.1.0
R5(config-router)#network 50.50.50.0

路由器R6

R6(config)#router rip
R6(config-router)#version 2
R6(config-router)#no auto-summary
R6(config-router)#network 1.1.1.0

路由器R7

R7(config)#router rip
R7(config-router)#version 2
R7(config-router)#auto-summary
R7(config-router)#network 1.1.1.0
R7(config-router)#network 40.40.40.0

路由器R8

R8(config)#router rip
R8(config-router)#version 2
R8(config-router)#no auto-summary
R8(config-router)#network 1.1.1.0
R8(config-router)#network 222.222.222.0

静态路由配置
路由器R3

R3(config)#ip route 0.0.0.0 0.0.0.0 60.60.60.60

路由器R4

R4(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.1

路由器R5

R5(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.5

路由器R6

R6(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.9

路由器R7

R7(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.13

6.服务器

DNS服务器配置
在这里插入图片描述FTP服务器配置
在这里插入图片描述

已标记关键词 清除标记
相关推荐
第一章、 前言……………………………………………………………………5 第二章、 需求分析………………………………………………………………6 2.1 概括………………………………………………………………………6 2.2目的及要求………………………………………………………………7 2.3 功能………………………………………………………………………8 2.4 预期目标…………………………………………………………………11 第三章、 综合布线………………………………………………………………12 3.1 规范和标准………………………………………………………………12 3.1.1 设计规范和标准……………………………………………………12 3.1.2 工业企业通信设计规范……………………………………………13 3.2 设计范围及要求…………………………………………………………13 3.2.1 设计范围……………………………………………………………13 3.2.2 设计规范的确定……………………………………………………13 3.2.3 布线要求…………………………………………………………14 3.3 系统设计…………………………………………………………………14 3.3.1 工作区子系统的设计………………………………………………14 3.3.2 水平子系统的设计…………………………………………………14 3.3.3 管理子系统的设计…………………………………………………15 3.3.4 干线子系统的设计…………………………………………………15 3.3.5 设备间子系统的设计………………………………………………15 3.3.6 建筑群子系统的设计………………………………………………16 第四章、 校园网络总体规划设计………………………………………………18 4.1 项目设计原则……………………………………………………………18 4.2 主干网设计………………………………………………………………19 4.3 图书馆网络设计…………………………………………………………19 4.4 宿舍局域网设计…………………………………………………………20 4.5 教学楼区网络设计………………………………………………………20 4.6 学院礼堂网络……………………………………………………………21 4.7 IP地址的分配……………………………………………………………21 第五章、 设备选型………………………………………………………………23 5.1 服务器……………………………………………………………………23 5.2 防火墙……………………………………………………………………24 5.3 机柜………………………………………………………………………24 5.4 路由器……………………………………………………………………24 5.5 交换机……………………………………………………………………25 5.6 PC机………………………………………………………………………26 第六章、 网络安全与防护技术…………………………………………………27 6.1 计算机网络安全…………………………………………………………27 6.1.1 计算机网络安全的目的和功能…………………………………27 6.1.2 网络安全的潜在威胁……………………………………………28 6.1.3 网络安全的策略………………………………………………28 6.2 防火墙技术……………………………………………………………29 6.2.1 防火墙的概念…………………………………………………29 6.2.2 防火墙的作用和特性…………………………………………29 6.2.3 实现防火墙的主要技术………………………………………29 6.2.4 防火墙的体系结构……………………………………………30 6.2.5 防火墙选择原则………………………………………………31 6.2.6 防火墙的配置…………………………………………………31 第七章、 工期及费用…………………………………………………………32 第八章、 代码…………………………………………………………………34 第九章、 鸣谢…………………………………………………………………36 第十章、 参考文献……………………………………………………………37
©️2020 CSDN 皮肤主题: 成长之路 设计师:Amelia_0503 返回首页